linux-2.6.31.6 doesn't boot

Ken Moffat zarniwhoop73 at googlemail.com
Sun Nov 29 14:00:47 PST 2009


2009/11/29 Alberto Hernando <pajaro.go at gmail.com>:
> Hi.
>
> I'm building LFS-6.5 (-svn, actually), and I can't make it boot. I've done
> the same in two machines, an old athlon amd and a pentium-iv. Kernel builds
> fine in both systems, but none of them can boot. The error is the same, VFS
> can't find a valid root system, "please add a valid root option". I'm using
> lilo. I've made sure that ext3 is built inside the kernel, and I'm using old
> configs from 2.6.26 and 2.6.28. I think both configs are ok, and /etc/fstab
> is as the book says. I can't find the mistake.

At some point (I thought it was *before* 2.6.28, but maybe I'm mistaken)
the kernel option for IDE disks changed (as part of the move to libata).
Unfortunately, all my systems use SATA drives, so I'm not entirely sure
which option is relevant.

On my current kernel (2.6.32-rc) I have
CONFIG_ATA=y
CONFIG_ATA_SFF=y # I don't recall what that does
CONFIG_SATA_VIA=y (the driver I'm using).

If you have a parallel ATA disk (40 or 80-way cable)
you'll need one or more of the CONFIG_PATA selections
to provide the driver.

This is one of the reasons I prefer to build a kernel on an
existing installed system first - it lets me confirm that what
I have chosen in the .config will let me boot (or not!).

Also, with  libata drivers you will need to specify /dev/sdXn
in /etc/fstab, instead of /dev/hdXn - for an older system,
mounting by label [man e2label] is helpful for the change.

Meanwhile, lilo is unlikely to be the problem (it still works for
me).

ĸen
-- 
After tragedy, and farce, "OMG poneys!"



More information about the lfs-support mailing list