5.5. GCC-4.4.1 - Pass 1

Вячеслав Блинников slavmfm at gmail.com
Mon Nov 30 00:04:10 PST 2009

It's my first LFS practice.
I successfully installed Binutils. Then I followed the second pass and
"unTARed" the "gmp" and "mpfr" packages:

tar -jxf ../mpfr-2.4.1.tar.bz2
mv -v mpfr-2.4.1 mpfr
tar -jxf ../gmp-4.3.1.tar.bz2
mv -v gmp-4.3.1 gmp

As second pass follows the first pass, I think that it's need to make
this coommands from "/mnt/lfs/sources/binutils-build/" directory.
Then, when I run

../gcc-4.4.1/configure \
    --target=$LFS_TGT --prefix=/tools \
    --disable-nls --disable-shared --disable-multilib \
    --disable-decimal-float --disable-threads \
    --disable-libmudflap --disable-libssp \
    --disable-libgomp --enable-languages=c

from "/mnt/lfs/sources/gcc-build" I get the configure error: "cannot
find gmp and mpfr: try use --with-gmp and --with-mpfr ".
I tried to install the gmp and mpfr packages and configure command
passed without errors. But make failed.

What I must to do else between installing binutils and gcc?


More information about the lfs-support mailing list