build problem LFS 6.5

stosss stosss at gmail.com
Sat Nov 28 02:36:21 PST 2009


On Sat, Nov 28, 2009 at 5:12 AM, Timothy Rice <t.rice at ms.unimelb.edu.au> wrote:
>> I am using the lfs 6.3 last version LiveCD. The computer does not have
>> anything installed on it.
>> I started over. I deleted the partitions on the hard drive and created
>> new ones and started at the beginning of the book. I have been running
>> the commands manually by copy and paste at the cli. Everything
>> appeared to be fine until now.
>>
>> lfs 6.5 chapter 6.15 GCC-4.4.1
>
> Hi Stosss,
>
> You say you are using the lfs 6.3 LiveCD on a computer with nothing else
> on it. This would imply that your computer only has the sources
> appropriate to lfs 6.3. However, you mention lfs 6.5 as the book you are
> working through.
>
> Are you using the sources for lfs 6.3, or have you done the wget thing to
> make sure you are using the sources appropriate to the lfs 6.5 book?
>
> I haven't looked at lfs 6.3, so I don't know how much difference it might
> make, but I am guessing that you could get weird things going on if you
> use methods from 6.5 to build the sources for 6.3.

I am only using the lfs 6.3 LiveCD (this is the newest and last lfs
LiveCD released) so I will have a working environment to build  lfs
6.5. You don't have to have a Linux OS installed on the hard drive
where you are building lfs if you have a LiveCD (any LiveCD). The
LiveCD lets you have network access so I can pull all the lfs 6.5
tarballs over. I have the lfs 6.5 book on another computer sitting
next to the machine I am trying to build lfs 6.5 on.



More information about the lfs-support mailing list