Segmentation fault after stripping

linux fan linuxscratch at gmail.com
Mon Nov 23 13:02:12 PST 2009


Segmentation fault occurs right after stripping in chapter05.

I am building lfs trunk using jhalfs trunk.

The stripping step succeeds, but the next step which is to
restore-luser-env errors. The restore-luser-env step only has to copy
the saved $(LUSER_HOME)/.bashrc.XXX back to .bashrc, but that fails:
--------------------------------------------------------------------------------
 Building target 058-stripping
 [++++++++++|                                                 ] 0 min. 10 sec
 Target 058-stripping OK
--------------------------------------------------------------------------------
/bin/bash: line 1: 27848 Segmentation fault      make BREAKPOINT=074-gcc LUSER
make: *** [mk_LUSER] Error 139

As you can see, the stripping succeeded, but it immediately fails on
the next bash command.

Here is from sys.log:
Nov 23 15:25:32 lfs sudo:      wnh : TTY=pts/0 ; PWD=/mnt/lfs/jhalfs ;
USER=root ; COMMAND=/bin/su - jhalfs -c source .bashrc && cd
/mnt/lfs/jhalfs && make BREAKPOINT=074-gcc LUSER
Nov 23 15:25:42 lfs kernel: make[27848]: segfault at 7b0 ip 40008fdd
sp bfccaaa0 error 4 in ld-2.11.so (deleted)[40000000+1d000]

I have the build backed up right after textinfo-ch5.
I have restored the build dir and restarted and it Segfaults every
time at the same place.

I tried a 20 second sleep at the end of the stripping, but it still Segfaults.

Any ideas?



More information about the lfs-support mailing list