Segmentation fault after stripping

linux fan linuxscratch at
Mon Nov 23 16:10:49 PST 2009

On 11/23/09, Aleksandar Kuktin wrote:
> As I have not tried jhalfs, a question, just to be clear: you are
> running the make command via automated means, after stripping, in a
> single slurp (from the same script)?

jhalfs automates from start to finish.
I have used it to build LFS 6.2.0, 6.3, and 6.4 and it never had a
problem on the stripping.

> If so, try running it manually after stripping. As in - your toolchain
> gets stripped, jou get your shell prompt back, and then you run the
> make command.

Last night, I tried restarting "make" after it came back to the shell
prompt and all kinds of system problems occurred :
  It barfed badly when trying to umount the build dir
  System choked on attempt to shutdown
  It just got the situation to be unstable
  The sys.log showed that the attempted umount triggered kernel bug/oops
  I managed to init 1 to single user mode to get as quiet as possible
before poweroff

So, I don't want to pretend that everything would be ok.
There seems to be something incompatible about doing stripping in the
development lfs book.

Right now, I set it to bypass the stripping altogether and it is in
the middle of building glibc-ch6 -- ok so far.

I could roll back to textinfo-ch5 if anybody has an idea to test how
to keep stripping from causing the segfaults.

More information about the lfs-support mailing list