boot problem LFS 6.5

Paul W. Lane kc9eye at
Mon Nov 23 02:56:00 PST 2009

On Mon, Nov 23, 2009 at 4:25 AM, stosss <stosss at> wrote:
> So I checked everything and even compiled the kernel again (3 more
> times) to make sure and got the same kernel panic telling me the same
> thing.
> I also ran the grub configuration 4 times:
> at the grub prompt root (hd0,0)
> setup (hd0)
> My HDD is hda1
> and in Grub I had:
> title LFS 6.5
> root (hd0,0)
> kernel /boot/lfskernel- root=/dev/hda1
> The kernel panic error was telling me to correct the root= part of the
> grub menu.lst.
> It was telling me to use sda1 instead of hda1 (why I don't know). So I
> tried that to see what would happen.
> sawpon: /dev/hda5: stat failed: No such file or directory
> I have no idea what to do now. If I change grub back to hda1 like I
> had it then I get the kernel panic, if I leave grub set as
> root=/dev/sda1 then I get the swap and ext3 problem. So where and what
> is the problem? Where did I make my mistake?

This is the same problem I ran into. The cause is the kernel module
for harddisks. It appears that the module does not name devices
starting with "hd" anymore. All devices are named as "sd" now. I
believe this has to due with only using the scsi driver and not libata
or something of the like. Anyway the solution is to now assume your
devices are all "sd" and not "hd". Leave the menu.lst as you have
configured it, with root=/dev/sda1, and edit your two entries in
/etc/fstab, renaming all instances of "/dev/hd#" to "/dev/sd#", minus
the quotes.

"Life after all, is a fatal disease, and the mortality rate
for humans, at the end of the day is 100%."
K.C. Cole (from The Universe and the Teacup)

More information about the lfs-support mailing list