boot problem LFS 6.5

Simone Dalmasso simone.dalmasso at
Mon Nov 23 02:55:06 PST 2009

Hi, I had a similar problem and the solution was to recompile the kernel
with the correct driver for the hard disk. In my case the hard disk was a
vmware partition. In your case seems that the kernel can't read the hda1. If
you can, try to do an lspci and look for what HD you have than check you
kernel conf file if the driver is set =yes.
Hope helps.


2009/11/23 stosss <stosss at>

> I went through the lfs 6.5 book and copied and pasted all the commands
> in the book to a series of shell scripts. I only made changes where it
> was necessary like with stuff like hda1 and hda5 other than that I
> left the commands in the book in tact. I used two partitions hda1 and
> hda5. The lfs build was done on an empty drive (with no installed OS
> on the machine) using the lfs 6.3 LiveCD the last release of that
> LiveCD. I had no compilation errors and no problems until I tried to
> boot.
> My problem originated with a problem addressed here:
> FAQ Kernel panic: VFS: unable to mount root fs
> So I checked everything and even compiled the kernel again (3 more
> times) to make sure and got the same kernel panic telling me the same
> thing.
> I also ran the grub configuration 4 times:
> at the grub prompt root (hd0,0)
> setup (hd0)
> My HDD is hda1
> and in Grub I had:
> title LFS 6.5
> root (hd0,0)
> kernel /boot/lfskernel- root=/dev/hda1
> The kernel panic error was telling me to correct the root= part of the
> grub menu.lst.
> It was telling me to use sda1 instead of hda1 (why I don't know). So I
> tried that to see what would happen.
> title LFS 6.5
> root (hd0,0)
> kernel /boot/lfskernel- root=/dev/sda1
> I got a new set of errors and I have not been able to find anything
> that addresses the problem.
> The new series of errors are:
> sawpon: /dev/hda5: stat failed: No such file or directory
> mounting root file system in read-only mode...
> Checking file systems...
> fsck.ext3: No such file or directory while trying to open /dev/hda1
> /dev/hda1:
> The superblock could not be read or does not describe a correct ext2
> filesystem. If the device is valid and it really contains an ext2
> filesystem (and not swap or ufs or something else), then the
> superblock is corrupt, and you might try running e2fsck with an
> alternate superblock:
> e2fsck -b 8193 <device>
> Then it said it has to be fixed manually and to press enter so the
> machine will stop and be powered off.
> I have no idea what to do now. If I change grub back to hda1 like I
> had it then I get the kernel panic, if I leave grub set as
> root=/dev/sda1 then I get the swap and ext3 problem. So where and what
> is the problem? Where did I make my mistake?
> --
> FAQ:
> Unsubscribe: See the above information page
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the lfs-support mailing list