glibc overwrites scsi.h

Alexander Kozlov akozlov at nada.kth.se
Thu Nov 19 02:34:06 PST 2009


> Does it matter that glibc-2.11 overwrites 
> /usr/include/scsi/scsi.h
> that has previously been installed by Linux-2.6.31.5 API Headers?
> 
> (Linux From Scratch - Version SVN-20091109)
> 
> Brett

I'm asking the same question.

As far as I can see in my Debian sid environment, starting with 
v2.6.31 linux installs include/scsi directory (4 files). This may 
also happen during the LFS build so both in Chap.5 and 6 glibc 
overwrites include/scsi/scsi.h thus leaving LFS with a mixture of 
the kernel and libc SCSI headers.

Before v2.6.31 LFS had libc headers only. Debian ships libc version 
of the /usr/include/scsi/* files. Which version should we use then? 
Should we suppress installation of the other one?

Alex.



More information about the lfs-support mailing list