Grub-1.97 problems

linux fan linuxscratch at gmail.com
Thu Nov 12 11:55:18 PST 2009


On 11/12/09, Bruce Dubbs <bruce.dubbs at gmail.com> wrote:

> The problem with GRUB Legacy is that it didn't support 64-bit systems --
> at least it have to be built from a 32-bit system.  This is a major
> drawback in that virtually every new Intel/AMD system is 64-bit capable.

Ok, maybe I just keep this in my back pocket:
URL="ftp://alpha.gnu.org/gnu/grub/grub-0.97.tar.gz"
patch -Np1 -i ../grub-0.97-disk_geometry-1.patch
patch -Np1 -i ../grub-0.97-256byte_inode-1.patch
./configure --prefix=/opt/grub1 &&
make &&
make install

and be so.. careful.. to be the 'grub-install' I want at the time.



More information about the lfs-support mailing list