Grub-1.97 problems

linux fan linuxscratch at gmail.com
Thu Nov 12 09:39:24 PST 2009


On 11/11/09, Bruce Dubbs <bruce.dubbs at gmail.com> wrote:
>
>> # grub-install --grub-setup=/bin/true  /dev/sda11
>
> This should be /dev/sda, but I see you tried that too.

Now I really _want_ to install grub on individual partitions so that I
can chainloader to different installations like grub-legacy has let me
do for years.

grub-install /dev/sdb8
grub-setup: warn: Attempting to install GRUB to a partition instead of
the MBR.  This is a BAD idea.
grub-setup: warn: Embedding is not possible.  GRUB can only be
installed in this setup by using blocklists.  However, blocklists are
UNRELIABLE and its use is discouraged.
grub-setup: error: If you really want blocklists, use --force.

USE THE FORCE, LUKE ...

grub-setup --force /dev/sdb8
grub-setup: warn: Attempting to install GRUB to a partition instead of
the MBR.  This is a BAD idea.
grub-setup: warn: Embedding is not possible.  GRUB can only be
installed in this setup by using blocklists.  However, blocklists are
UNRELIABLE and its use is discouraged.

It didn't ...
It it didn't put grub on /dev/sdb8 ... the grub-legacy is still there
"GNU Grub 0.97"

Plus, grub-legacy used to let you "setup grub" from the grub command
line is you had booted from a floppy, or a cd, or some other way.

I think that is a major function loss.



More information about the lfs-support mailing list