Grub-1.97 problems

Bruce Dubbs bruce.dubbs at
Wed Nov 11 19:34:38 PST 2009

linux fan wrote:
> Since lfs dev has switched to grub2,.I want to try it.
> I don't know why grub2 fails to work properly on my system.
> It seems to choke on partitions/filesystems on my sata hard drives.
> I built grub-1.97 exactly from the instructions in lfs dev.
> Searching google proved fruitless in solving the bizarre failure messages:
> error: cannot seek `/dev/sda'
> grub-probe: error: Cannot find a GRUB drive for /dev/sda11.  Check
> your

OK, I assume you are still within the chroot environment.

> # mount
> /dev/sda11 on / type ext3 (rw)

Should be OK.

> # grub-install --grub-setup=/bin/true  /dev/sda11

This should be /dev/sda, but I see you tried that too.

What is the result of:

ls -l /dev/sd*

> # grub-mkdevicemap
> # cat /boot/grub/
> (fd0)   /dev/fd0
> (hd0)   /dev/sda
> (hd1)   /dev/sdb

This looks OK.

> # ls /boot/grub

Looks OK.

Lets see if we can get the grub-install command to work properly first 
and then we can address other issues.  *Within the chroot environment* 
remove all files in /boot/grub and check that /dev/sda and /dev/sdb are 
present (at a minimum).  Then try

   grub-mkdevicemap --verbose

The only thing in /boot/grub should be  Now try:

   grub-install --grub-setup=/bin/true  /dev/sda

let us know if you still get the error: cannot seek `/dev/sda' error.

   -- Bruce

More information about the lfs-support mailing list