Error at 5.8 Adjusting the Toolchain (Last stable version of the book)

Bruce Dubbs bruce.dubbs at gmail.com
Thu Nov 5 12:54:10 PST 2009


pieter blomme wrote:
> This is wat version-check.sh outputs (after I installed gawk (again, I had
> already done once manually from the soundcloud database, but something might
> have gone wrong ofcourse)):
> 
> bash, version 4.0.33(1)-release
> /bin/sh -> /bin/dash

First mistake. Change the symlink

> Binutils: (GNU Binutils for Ubuntu) 2.20
> bison (GNU Bison) 2.4.1
> yacc not found

Second mistake. Create the symlink

> bzip2,  Version 1.0.5, 10-Dec-2007.
> Coreutils:  7.4
> diff (GNU diffutils) 2.8.1
> find (GNU findutils) 4.4.2
> GNU Awk 3.1.6
> /usr/bin/awk -> /usr/bin/gawk
> gcc (Ubuntu 4.4.1-4ubuntu8) 4.4.1
> GNU C Library (EGLIBC) stable release version
> GNU grep 2.5.4
> gzip 1.3.12
> Linux version 2.6.31-14-386 (buildd at rothera) (gcc version 4.4.1 (Ubuntu
> 4.4.1-4ubuntu8) ) #48-Ubuntu SMP Fri Oct 16 16:41:14 UTC 2009
> m4 (GNU M4) 1.4.13
> GNU Make 3.81
> patch 2.5.9
> Perl version='5.10.0';
> GNU sed version 4.2.1
> tar (GNU tar) 1.22
> ./version-check.sh: line 32: makeinfo: command not found

Third mistake.  sudo apt-get install texinfo

Fourth mistake. Don't top post.

   -- Bruce




More information about the lfs-support mailing list