Error at 5.8 Adjusting the Toolchain (Last stable version of the book)

William Immendorf will.immendorf at gmail.com
Thu Nov 5 12:32:01 PST 2009


On Thu, Nov 5, 2009 at 2:28 PM, pieter blomme <pieter.blomme at gmail.com> wrote:
> Checking the config.log didn't teach me a lot of new things.  But the error
> came before installing Binutils in second pass allready.  Judging by the
> error, I suppose it has to do with the C-compiler, so here's the Glibc make
> and make install output from the shell:
> mawk -f scripts/gen-sorted.awk
> \
>                -v subdirs='csu assert ctype locale intl catgets math setjmp
> signal stdlib stdio-common libio malloc string wcsmbs time dirent grp pwd
> posix io termios resource misc socket sysvipc gmon gnulib iconv iconvdata
> wctype manual shadow gshadow po argp crypt nss localedata timezone rt
> conform debug  dlfcn elf'
The reason that Glibc can't compile is that you have Mawk on your
system. Just run:

sudo apt-get install gawk

and try recompiling glibc. Oh, and what does version-check.sh output?


-- 
William Immendorf
The ultimate in free computing.

--------------

"Every nonfree program has a lord, a master --
and if you use the program, he is your master."  Richard Stallman



More information about the lfs-support mailing list