inetutils fails in compilation

Chris Staub chris at
Tue Nov 3 05:41:58 PST 2009

On 11/02/2009 08:45 PM, yayo wrote:
> Hello.
> I'm currently at chapter 6.31: Inetutils.
> I'm using a LFS-livecd (6.3) as host system and the version 6.5 of the LFS book.
> Also I'm using the last package management system mentioned in the LFS book itself, the one named "user based management" (with just some little problems all solved so far).
> I tried building Inetutils but the process fails.
> This is the last part of the building log, the part which seems to have something wrong:
>      gcc -std=gnu99  -g -O2   -o ftp cmds.o cmdtab.o domacro.o ftp.o main.o ruserpass.o -L../libinetutils -linetutils -L../lib -lgnu  -lreadline -lcurses -lhistory -lresolv -lnsl
>      /usr/lib/gcc/i686-pc-linux-gnu/4.4.1/../../../libreadline.a(xmalloc.o): In function `xrealloc':
>      /usr/src/readline/readline-6.0/xmalloc.c:71: multiple definition of `xrealloc'
>      ../lib/libgnu.a(xmalloc.o):/usr/src/inetutils/inetutils-1.6/lib/xmalloc.c:60: first defined here
>      /usr/lib/gcc/i686-pc-linux-gnu/4.4.1/../../../libreadline.a(xmalloc.o): In function `xmalloc':
>      /usr/src/readline/readline-6.0/xmalloc.c:58: multiple definition of `xmalloc'
>      ../lib/libgnu.a(xmalloc.o):/usr/src/inetutils/inetutils-1.6/lib/xmalloc.c:48: first defined here
>      collect2: ld returned 1 exit status
>      make[2]: *** [ftp] Error 1
>      make[2]: Leaving directory `/usr/src/inetutils/inetutils-1.6/ftp'
>      make[1]: Leaving directory `/usr/src/inetutils/inetutils-1.6'
>      make[1]: *** [all-recursive] Error 1
>      make: *** [all] Error 2

Looks like it's trying to find something in Readline's source directory, 
but I have no idea why it would be looking there. And yes, as Ken said, 
trying to use

> Also, in the make.log excerpt that I posted for 1st, you can see some messages related to Readline. I don't get if they are either just warnings or errors. The config.log has something about readline too, but nothing which stopped the configuration process. Just many notes to some undefined references, like this one
>      /usr/src/readline/readline-6.0/terminal.c:531: undefined reference to `tgetflag'
>      collect2: ld returned 1 exit status

Messages like this generally indicate that Ncurses is not being found. I 
would check that Ncurses are Readline are actually installed as they're 
supposed to be. What do you get when you do "ls -l {,/usr}/lib/*curses*" 
and "ls -l {,/usr}/lib/*readline*"?
> I don't get what's wrong. : /
> I asked in the IRC channel, and checked the mailing-list archive, but didn't find anything.
> Someone has suggestions (except for "restart from beginning of chapter 6" : P)?
> Thanks. : )
> yayo

More information about the lfs-support mailing list