inetutils fails in compilation

yayo yayo.75 at
Mon Nov 2 17:45:12 PST 2009


I'm currently at chapter 6.31: Inetutils.
I'm using a LFS-livecd (6.3) as host system and the version 6.5 of the LFS book.
Also I'm using the last package management system mentioned in the LFS book itself, the one named "user based management" (with just some little problems all solved so far).

I tried building Inetutils but the process fails.

This is the last part of the building log, the part which seems to have something wrong:

    gcc -std=gnu99  -g -O2   -o ftp cmds.o cmdtab.o domacro.o ftp.o main.o ruserpass.o -L../libinetutils -linetutils -L../lib -lgnu  -lreadline -lcurses -lhistory -lresolv -lnsl 
    /usr/lib/gcc/i686-pc-linux-gnu/4.4.1/../../../libreadline.a(xmalloc.o): In function `xrealloc':
    /usr/src/readline/readline-6.0/xmalloc.c:71: multiple definition of `xrealloc'
    ../lib/libgnu.a(xmalloc.o):/usr/src/inetutils/inetutils-1.6/lib/xmalloc.c:60: first defined here
    /usr/lib/gcc/i686-pc-linux-gnu/4.4.1/../../../libreadline.a(xmalloc.o): In function `xmalloc':
    /usr/src/readline/readline-6.0/xmalloc.c:58: multiple definition of `xmalloc'
    ../lib/libgnu.a(xmalloc.o):/usr/src/inetutils/inetutils-1.6/lib/xmalloc.c:48: first defined here 
    collect2: ld returned 1 exit status
    make[2]: *** [ftp] Error 1
    make[2]: Leaving directory `/usr/src/inetutils/inetutils-1.6/ftp'
    make[1]: Leaving directory `/usr/src/inetutils/inetutils-1.6'
    make[1]: *** [all-recursive] Error 1
    make: *** [all] Error 2

I can't see anything else wrong in the rest of the making log.
I fist checked for something else related to that "collect2: ld returned 1 exit status": I tried with the config.log file but it's huge.
Anyway I managed to locate the 1st position which seems to report an error, and the error message is similar, still complaining about a failure in "ld":

    configure:4536: gcc -o conftest -g -O2   conftest.c -lcposix   >&5
    /usr/bin/ld: cannot find -lcposix
    collect2: ld returned 1 exit status

it seems to be something wrong with an "-lcposix" option.
Anyway the configure process didn't stop for that and reached the end without complaining for errors.

Also, in the make.log excerpt that I posted for 1st, you can see some messages related to Readline. I don't get if they are either just warnings or errors. The config.log has something about readline too, but nothing which stopped the configuration process. Just many notes to some undefined references, like this one

    /usr/src/readline/readline-6.0/terminal.c:531: undefined reference to `tgetflag'
    collect2: ld returned 1 exit status

and the configuration output seems to be ok about this:

    checking for readline...  -lncurses
    checking how to link with libreadline... /usr/lib/libreadline.a -lncurses
    checking readline/readline.h usability... yes
    checking readline/readline.h presence... yes
    checking for readline/readline.h... yes

I don't get what's wrong. : /
I asked in the IRC channel, and checked the mailing-list archive, but didn't find anything.
Someone has suggestions (except for "restart from beginning of chapter 6" : P)?
Thanks. : )


(p.s. I get the LFS-support emails in form of digest, so I cannot reply to a single email, and I fail in getting the discussion sorted in a thread.
I don't know how to do it. Any time I tried in the past my reply started a new thread. I'm sorry for this. : / )


More information about the lfs-support mailing list