LFS 6.4 now boots

Jaiyson jaiyson at sympatico.ca
Sun May 31 12:42:11 PDT 2009

So I finally got my LFS to boot....thanks Gerard, Hugh and Bruce for 
giving suggestions on how to make it so....

I thought I would write out what I did to get it working so if other 
newbies like myself come along and have the same problems they can 
use the info to help...

I hope posting this the way I am keeps it in the thread...if admin 
would like me to repost differently so it keeps in the thread please 
let me know...

So first thing I started on was Gerards suggestions since I got his 
message first and which was to check for IDE drivers, chipsets, and 
filesystems through the menuconfig step in chapter 8.3.1 (LFS 6.4 book)

Of course while chrooted in lfs I could not use lspci to find out my 
system information or cfdisk to verify my partition for lfs was the 
ext3 I thought it was; I also noticed that you cannot echo things 
like $LFS or $LC_ALL or $LANG to the moniter while chrooted, which I 
don't think was important for getting the system to boot but when I 
was entering the line in ch. 8.3.1 for menuconfig it says to use the 
host $LANG value to replace - host_LANG_value -. I tried to find out 
what that value was using echo just to make sure there was a value 
there and found out echo doesn't work...so I just used 
$LC_ALL  hoping it would not turn out to be a factor in glitching the process.

So I logged out and through cfdisk found out that yes my partition 
was ext3...and used lspci to find out that I had an IDE device and 
ISA bridge device on the system and that my processor was a 

With that info I went through the process a few times of:   the steps 
of loading up the LFS live disk, export LFS=/mnt./lfs, mkdir $LFS, 
mount /dev/hda2  $LFS, mounting and pop /dev (ch. 6.2.2), mounting 
virtual kernel file systems (ch. 6.2.3) then straight to chapter 8.3.1.

I think once I forget to do the mrproper step before recompiling(if 
that makes a difference I don't know);

Another time grub simply would not even recognize seeing any 
partitions at all; the TAB technique would not work at all either...

Another time I forget to mark off my celeron(coppermined) in 
config...although for booting it may not matter since it has generic 
486 set off as default.

I also verfied my /etc/fstab settings too along the way

Once I tried the suggestion to change 'h' with 's' in grub but grub 
wouldn't let me do that.

In the end, while in menuconfig, I think it was a few 
sub-settings(that I did not do before) I tried under the Drivers - 
ATA/ATAPI/MFM/RLL category that made the difference. I can't be more 
specific in that regard since being booted in lfs now I can only look 
at the config file with vim which lays out the information 
differently and can't prompt my memory well enough.

One thing I would like to say for other newbies is that when you 
enter that menuconfig part in section 8.3.1 each item in it has a 
help tab that gives very useful information about that particular 
setting. I Tabbed through all of the kernel options and read most of 
those help files. They're

not large like Man files but still gives you good info to make 
decisions on including an item or not.  So having looked at what 
hardware I have and using the help files I added some of these which 
are not set to default( for the most part that my memory serves) with 
kernel source:

Processor type and features;
CONFIG_MPENTIUNIII=y   (for my celeron-coppermine)

Bus options;

PC-card bridges;
CONFIG_I82365=y  (this items help file had info that seemed related 
to my ISA bridge listing from lspci)

Device Drivers  -  Generic Driver Options;

IDE chipset support/bugfixes

PCI IDE chipset support;
CONFIG_BLK_DEV_SIS5513=y (SIS being the chipset maker and this 
setting covering a number of chipsets by that manufacturer)

Other IDE chipsets support;

I also looked over filesystems for ext3 but found they are all set by 
default so that was not the problem.

Thanks again guys for your help in finally getting this done!

More information about the lfs-support mailing list