Unable to boot LFS 6.4

Jaiyson jaiyson at sympatico.ca
Fri May 29 19:52:24 PDT 2009

Hello:  I was hoping someone may be able to help since I am unable to 
boot with my build.

I'm using LFS-BOOK-6.4 and the live cd(x86-6.3-r2160) as a host

I downloaded and used the sources including patches recommended in 
book (not the ones from the cd)

my LFS build is on /dev/hda2 and was formatted as per book  ( I 
mentioned this because the error message mentions something about NFS 
and I have no NFS partitions on my disk)

here are the lines leading up to the boot stopping :

[  2.415272] md: ...autorun DONE.
[  2.415643] Root-NFS: No NFS server available, giving up.
[  2.415749] VFS: Unable to mount root fs via NFS, trying floppy.
[  2.417123] VFS: Cannot open root device "hda2" or unknown-block(2,0)
[  2.417224] Please append a correct "root=" boot option; here are 
the available partitions:
[  2.417360] Kernel panic - not syncing: VFS: Unable to mount root fs 
on unknown-block(2,0)

I searched the archives and there seemed to be a guy named martin who 
had a similar problem last feb '08 , but I couldn't find anything 
there that pertained to me or anything to try

I checked my fstab file which is for the first entry:

/dev/hda2     /      ext3   defaults     1    1

I tried a few things...

Before finishing and trying to boot I noticed when I did the grub 
setup that I did not copy    e2fs_stage1_5

so I went back and added that and then finished grub while as:

chroot "$LFS" /usr/bin/env -i \
HOME=/root TERM="$TERM" PS1='\u:\w\$ ' \
PATH=/bin:/usr/bin:/sbin:/usr/sbin \
/bin/bash --login

from chapter 6.61 - as a note and I don't know if it makes a 
difference in chapter 6.60 but $TERM is without quotes.

After copying e2fs_stage1_5 file I finished grub which was:

root (hd0,1)

setup (hd0)

I then went and finished remaining instructions and rebooted with 
same boot errors as above.

After that I went back and chrooted as per chapter 6.2.2   6.2.3  and 6.4

and tried re-compiling and re-installing Grub and when going to grub 
this time adding along with e2fs_stage_5 also reiserfs_stage1_5 and 

I finished remaining steps again but to no avail with same error 
message as above.

Because I noticed in the previous posts last year something about the 
NFS problem relating to networks I thought I would look into that 
section of the book which is 7.13 ( Configuring the network Script )

For my build I decided to not to use my network card and the 
instructions say " If a network card will not be used, there is 
likely no need to create any configuration files relating to network cards.
If that is the case, remove the network symlinks from all run-level 
directories (/ etc/ rc. d/ rc*. d). "

For some reason I missed reading that part so I went into those sub 
directories eg. /etc/rc.d/rc1.d , and removed all files with network 
in their name...I think there was only 2 types populated...something 
like S20network... and K80network...

I made a hostname with:

echo "HOSTNAME=lfs_64" > /etc/sysconfig/network

My /etc/hosts was made with:

cat > /etc/hosts << "EOF"

# Begin /etc/hosts (no network card version) HOSTNAME.example.org   HOSTNAME localhost

# End /etc/hosts (no network card version)


Again I finished the remaining instructions and tried to reboot with 
same results as above.

The only thing I can think of right now is that I did not remove the 
correct symlinks for  /etc/rc.d/* .  Maybe these are not the links 
themselves but are pointed to?

I was also thinking is that both re-installing grub and removing 
symlinks occur before install of linux kernel( in the 
instructions...perhaps that should have been(linux) recompiled 
because maybe the kernel incorporates some of these elements and not 
just what was unpacked from its own tar files?

Any help is appreciated thank you.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.linuxfromscratch.org/pipermail/lfs-support/attachments/20090529/a868f6e2/attachment.html>

More information about the lfs-support mailing list