Compilation error in 5.7. Glibc-2.8-20080929

Chris Staub chris at beaker67.com
Sat Mar 21 21:00:03 PDT 2009


Hugh wrote:
> • The version of the book being used: 6.4
> • The host distribution and version being used to create LFS: Debian Lenny
> • The package or section the problem was encountered in: 5.7. Glibc-2.8-20080929
> • The exact error message or symptom being received:
> 
> ==========beginning of the error message======
> mawk: scripts/gen-sorted.awk: line 19: syntax error at or near ]
> mawk: scripts/gen-sorted.awk: line 19: runaway regular expression /,
> 
> Hi all,
> 
> Have I made anything wrong? What to do to solve this problem? Thanks in advance.
> 
> Regards,
> Hugh

You missed a page - 
http://www.linuxfromscratch.org/lfs/view/6.4/prologue/hostreqs.html - 
make sure your host system has everything listed here. This particular 
problem is caused by missing Gawk.



More information about the lfs-support mailing list