Compilation error in 5.7. Glibc-2.8-20080929

Hugh hugh.shang at gmail.com
Sat Mar 21 20:48:40 PDT 2009


• The version of the book being used: 6.4
• The host distribution and version being used to create LFS: Debian Lenny
• The package or section the problem was encountered in: 5.7. Glibc-2.8-20080929
• The exact error message or symptom being received:

==========beginning of the error message======
mawk: scripts/gen-sorted.awk: line 19: syntax error at or near ]
mawk: scripts/gen-sorted.awk: line 19: runaway regular expression /,
"", subd ...
make[1]: Leaving directory `/mnt/lfs/sources/glibc-2.8-20080929'
make[1]: Entering directory `/mnt/lfs/sources/glibc-2.8-20080929'
mawk -f scripts/gen-sorted.awk \
           -v subdirs='csu assert ctype locale intl catgets math
setjmp signal stdlib stdio-common libio malloc string wcsmbs time
dirent grp pwd posix io termios resource misc socket sysvipc gmon
gnulib iconv iconvdata wctype manual shadow po argp crypt nss
localedata timezone rt conform debug libidn dlfcn elf' \
           -v srcpfx='' \
           nptl/sysdeps/pthread/Subdirs sysdeps/unix/inet/Subdirs
sysdeps/unix/Subdirs assert/Depend intl/Depend catgets/Depend
stdlib/Depend stdio-common/Depend libio/Depend malloc/Depend
string/Depend wcsmbs/Depend time/Depend posix/Depend iconvdata/Depend
nss/Depend localedata/Depend rt/Depend debug/Depend >
/mnt/lfs/sources/glibc-build/sysd-sorted-tmp
mawk: scripts/gen-sorted.awk: line 19: regular expression compile
failed (bad class -- [], [^] or [)
/[^
mawk: scripts/gen-sorted.awk: line 19: syntax error at or near ]
mawk: scripts/gen-sorted.awk: line 19: runaway regular expression /,
"", subd ...
rm -f /mnt/lfs/sources/glibc-build/stamp.o; >
/mnt/lfs/sources/glibc-build/stamp.o
rm -f /mnt/lfs/sources/glibc-build/stamp.os; >
/mnt/lfs/sources/glibc-build/stamp.os
rm -f /mnt/lfs/sources/glibc-build/stamp.oS; >
/mnt/lfs/sources/glibc-build/stamp.oS
cd /mnt/lfs/sources/glibc-build && /tools/bin/ar cruv libc.a `cat stamp.o`
: /mnt/lfs/sources/glibc-build/libc.a
cd /mnt/lfs/sources/glibc-build && /tools/bin/ar cruv libc_pic.a `cat stamp.os`
: /mnt/lfs/sources/glibc-build/libc_pic.a
cd /mnt/lfs/sources/glibc-build && /tools/bin/ar cruv libc_nonshared.a
`cat stamp.oS`
: /mnt/lfs/sources/glibc-build/libc_nonshared.a
make[1]: *** No rule to make target
`/mnt/lfs/sources/glibc-build/Versions.all', needed by
`/mnt/lfs/sources/glibc-build/abi-versions.h'.  Stop.
make[1]: Leaving directory `/mnt/lfs/sources/glibc-2.8-20080929'
make: *** [all] Error 2
=======end of the error message======

Hi all,

Have I made anything wrong? What to do to solve this problem? Thanks in advance.

Regards,
Hugh



More information about the lfs-support mailing list