Best Version to Build?

Ken Moffat ken at linuxfromscratch.org
Wed Mar 18 09:38:50 PDT 2009


On Wed, Mar 18, 2009 at 10:07:43AM -0600, Mike McCarty wrote:
> 
> Are you saying that the BLFS for 6.3 will run fine with 6.4? I'd think
> so. Also, as you note, I really don't care about the L&G GUI stuff.
> I do my maintenance using a CLI, anyway. I might want a later GIMP
> and maybe EOG (mine can't print).
> 
 BLFS covers many things.  I have little recent experience of server
applications, and I certainly haven't tried to build large parts of
BLFS-6.3 on a more recent system (my normal builds were using newer
xorg and gnome (part of) even before BLFS-6.3 was released).

 There are the following changes in LFS-6.4 which are relevant to
packages in BLFS:

1. Changes in kernel headers.
2. Changes in glibc (headers, typically moving things around).
3. Newer versions of g++ (4.2 a little, 4.3 a lot) have much tighter
'scope' rules.

 Sometimes, there is a patch in -patches.

 Sometimes, the instructions and package version in BLFS-svn will
solve the problem (but other times they will require correspondingly
newer versions of their dependencies).

 Sometimes, the wiki may be helpful.

 I recommend you to look at the BLFS -dev and -support archives
since last October.

 There is no "standard" set of packages in BLFS.  Undoubtedly, some
of them "just work".

ĸen
-- 
das eine Mal als Tragödie, das andere Mal als Farce



More information about the lfs-support mailing list