lfs 6.4 compiled on a vmware host

Dave dave.mehler at gmail.com
Tue Jun 30 07:10:18 PDT 2009

	Has anyone got lfs 6.4 going on a vmware server host? Currently i
don't have machines to try it out on so am having to do it on a vm. I've got
a centos 5.3 server vm going and i've added a second virtual hard disk an
IDE disk to it for lfs. I've completed the lfs book and the machine is
bootable, i know this because i power down the centos vm, remove the hd vm
files and put them in another area, then create a new vm for lfs, and point
the hard disk to the bootable lfs drive. Problem 1 occurs on boot when i
think this is a vmware thing it wants to act as if the hd is scsi which it
isn't. I made it ide because the last time i tried an lfs install i made two
scsi drives /dev/sda which had the centos box on it and /dev/sdb which had
the lfs on it. When i took the /dev/sdb from the centos vm and tried to boot
it it was unbootable because grub wouldn't recognize it's mbr as valid when
i switched it over to sda on the new vm, so i figured to avoid that by
making this go an IDE drive. If anyone has lfs going in a vm i'd be

More information about the lfs-support mailing list