glibc build Error

rony jak ronnyjak at googlemail.com
Mon Jun 22 08:22:53 PDT 2009


hi all
after i successfully chroot to my temp LFS and on installing glibc while i
execute #make install command i got this error
//****************************ERROR**************************************
CC="gcc" /usr/bin/perl scripts/test-installation.pl /sources/glibc-build/
cc1: error: unrecognized command line option
"-W1,-dynamic-linker=/lib/ld-linux.so.2"
Execution of gcc failed!
The script has found some problems with your installation!
Please read the FAQ and the README file and check the following:
- Did you change the gcc specs file (necessary after upgrading from
  Linux libc5)?
- Are there any symbolic links of the form libXXX.so to old libraries?
  Links like libm.so -> libm.so.5 (where libm.so.5 is an old library) are
wrong,
  libm.so should point to the newly installed glibc file - and there should
be
  only one such link (check e.g. /lib and /usr/lib)
You should restart this script from your build directory after you've
fixed all problems!
Btw. the script doesn't work if you're installing GNU libc not as your
primary library!
make[1]: *** [install] Error 1
make[1]: Leaving directory `/sources/glibc-2.10.1'
make: *** [install] Error 2
root:/sources/glibc-build#
//****************************ERROR**************************************

is any solution ? can i reboot my pc and continue later or keep it running
until make install succeed  :)
i use ubuntu 9.04 and LFS-BOOK-SVN-20090606.pdf
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.linuxfromscratch.org/pipermail/lfs-support/attachments/20090622/c1654107/attachment.html>


More information about the lfs-support mailing list