Help.

Simon Geard delgarde at ihug.co.nz
Sat Jun 13 03:21:13 PDT 2009


On Fri, 2009-06-12 at 16:49 +0200, khaled gouaich wrote:
> Hi every body,
> i'm new in the LFS world and i'm trying to build my LFS. I'm using the
> LFS book 6.3 (English version).

First, I'd recommend using the 6.4 book instead - it's been out for a
good 6 months, and 6.3 is pretty old now (released 2007, I think?).

> My host : linux 2.6.24 with a good configuration (i got all the
> tools).

If the host is running that kernel, it certainly should be recent enough
not to have any odd compatibility problems. What is it running - a
recent Ubuntu or Fedora?

> I have a problem at chapter 5, 5.6.1 installing Glibc.
> I got this message :
> 
> *** WARNING: You should not compile GNU libc without versioning. Not
> using
> *** versioning will introduce incompatibilities so that old binaries
> *** will not run anymore.
> *** For versioning you need recent binutils (binutils-2.8.1.0.23 or
> newer).

I'm not an expert, but it's apparent it's having some problem with the
copy of binutils it's finding. It seems to be using the copy you've
installed in the earlier step (5.3.1), which is correct. The most likely
explanation is that you've made a mistake somewhere in one of these
steps - a mistyped command, or a command you've overlooked.

You could try starting again from the beginning, taking care with each
step (copying and pasting commands is the preferred way to avoid typing
errors).

(Sorry if this isn't a great deal of help.)

Simon.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 198 bytes
Desc: This is a digitally signed message part
URL: <http://lists.linuxfromscratch.org/pipermail/lfs-support/attachments/20090613/1af38097/attachment.sig>


More information about the lfs-support mailing list