Can't Boot Without Boot Disk--Bios Hosed?[SOLVED]

Dan McGhee beesnees at grm.net
Mon Jan 12 14:07:33 PST 2009


S D wrote:
>  I think your BIOS might be set to boot off the wrong disk. Since you
> reinstalled grub I'm guessing that was on the MBR of the LFSdisk so
> you need to point your bios at that. That way when you want to boot
> into windows it should flow something like:
>     BIOS -> LFSdisk MBR -> GRUB -> XPdisk MBR -> XPsystem.
> And when you boot into LFS it should flow like:
>     BIOS -> LFSdisk MBR -> GRUB -> LFSsystem.
>
> I've had similar troubles with Partition Magic 8 and find a much more
> reliable solution is to use the GParted or QParted live-CD, that way
> you can't change the system you are running the partitioner from and
> cause it to crash or wipe everything.
>   
I reported the wrong error on my boot-up. It was Error 2. GRUB wasn't 
recognizing the disk. I went "googling" again and ran across some 
articles, but now I can't find them to supply the links. The most 
interesting was that GRUB Legacy which is actually grub-0.97 is no 
longer maintained. Also, I learned that some e2fsprogs have opened their 
compatibility to ext4 and this is not compatible with GRUB. In all of 
this I found that my LFS build was 6.1.1. Didn't realize it was that 
old. I "shot-gunned" it. Therefore, I really don't know what the precise 
fix was. But, considering everything I read and the replies here, this 
is what I did:

1. I blanked the disk with Partition Magic 8.0
2. Upgraded my bios to the latest version and set CDROM as first boot 
device and then hd0 (that's the one with XP on it.)
3. Used liveCD-6.1.1-pre3 (couldn't believe I found it) and cfdisk to 
partition the drive.
4. Using the book on the liveCD, I created an ext2 filesystem.
5. Wanted to build grub-0.96 from that book, but it wouldn't install and 
I didn't want to take the time with it.
6. Installed grub-0.97 with its patch
7. Couldn't install configure grub
8. Toggled the boot flag with cfdisk
9. Shifted to lfsliveCD-6.2 (needed the tar version) and used its GRUB 
to configure GRUB on the hard drives.
10. Booted and all was fine.

Thank you both for the responses. They took me down the path I needed to go.

Dan



More information about the lfs-support mailing list