Can't Boot Without Boot Disk--Bios Hosed?

Anthony Price elenmar at
Mon Jan 12 06:20:56 PST 2009

Dan McGhee wrote:
> Posting to this list because of possible GRUB installation probs.
> Dual boot box with XP and (B)LFS on separate hard drives--XP on hda1 and 
> LFS on hdb1.  LFS 3 (?) years old--6.1 or 6.2.  Wanted to re-arrange 
> partitions and clean-up pending a new LFS build. Backed up everything to 
> external hard drive.  I used Nero for Windows and `tar -cf - . | tar 
> -xvf - -C <target>` for linux.  I might add that I hadn't done this 
> before becuase Partition Magic 8.0 in windows was reporting "bad 
> partition" table and wouldn't make any changes.
> I used Gparted live CD to make the partition changes that I wanted, used 
> a Nero boot CD to recover Windows and LFSLIVECD-6.3 to recopy LFS. So 
> far so good.
> When I rebooted I got GRUB error 22.  OK, so I used XP install disk and 
> ran fixmbr.  Now I could get to windows but not LFS.  Grub Error 15 "no 
> such file or directory."  Googling led me to the concept that grub's 
> stage{1,2} and e2fs-stage1_5 are images. So using the LFS live-cd and 
> version 6.2 of the book, I chrooted into LFS uninstalled, rebuilt and 
> re-installed GRUB-0.97.  Don't know what my mistakes were, but I went 
> through this iteration a couple (?) of times before <grub> setup (hd0) 
> reported that it had recognized and successfully installed itself to the 
> MBR.  Now I couldn't even boot to Windows.  So I started again.  One 
> thing that I did notice was the grub reported hd0 as ext3 and hd1 as 
> fat32.  That's just the opposite of the situation. 
> By this time I was pressing to fix and was tired.  Shoulda walked away. 
> I tried to "repair" my windows installation, but it looked like a 
> complete new install and I didn't complete it.  Wiped the hard drive and 
> tried again.  In the interim I had discovered the grub boot cd. Glad I 
> did because after the repair attempt, I ended up restoring with Nero 
> again, PC told me "trouble loading OS" at boot.  Now I can't boot 
> without that CD and only to windows.  Each time I try to boot LFS, I get 
> Error 15.
> When I try to set up grub using LiveCD and chroot, the results of `setup 
> (hd0) are
> checking stage1
> checking boot/grub/stage1
> no such file or directory
> In the grub shell `find boot/grub/stage1` gives
> file or directory does not exist.
> I'm stumped.  Can't find anything helpful by googling any more.  I can 
> only think that I have fallen pray to windows and DOS snobbishness and 
> am paying for using a non-windows based partition manager to do my work.
> The other possibility is that somehow I have hosed my bios.  It does 
> detect each hard drive and in the right order.  I've run Western 
> Digital's checks and the hard drives appear to be OK.
> I'm hoping that someone here can at least point me in the right 
> direction on this.  Hard drive and bios operations are absolutely my 
> weakest area in computing.
> Thanks in advance.
> Dan

I had something similar recently with a dual boot system. I think you 
will find that XP when installed on teh first HDD places the key bootup 
files NTLDR et al on the second physical disk.

I would try physically disconnecting the second disk, then repairing (or 
even reinstalling) XP.

There's no guarantee that this will work of course, but I think it's 
worth a try.



More information about the lfs-support mailing list