How to upgrade a package in a linux distribution?

Agathoklis D. Hatzimanikas a.hatzim at gmail.com
Sun Feb 8 02:56:38 PST 2009


Hi,

On Sun, Feb 08, at 12:07 petrele.chen wrote:
> Hi,all
> I want to install a package (ibus) in my ubuntu 8.04,
> it requires pygobject >= 2.15, but the host system only
> have 2.14 installed. What is the best way to upgade 
> this package.
> I thonght If I install it to /usr/local directory, It 
> may works. But during the configure of ibus, It reports 
> that pkg-config's return value is different from the directly
> detected value, and the procedue can not continue.
> May anybody can help me to solve this problem.

Sorry, but this is not the right mailing link to ask this kind
of questions.
I believe you will take better answers if you redirect this question
either to:

a. one of the specialized ubuntu forums, possible by opening a bug
   and make a request to update pygobject or to create another slot of
   the same package (I think that debian derivated distributions have
   this mechanism, I could be wrong though)

b. blfs-support mailing list, which is more suitable to answer questions
   for packages *beyond* the base lfs base system. However ibus
   is not a part of BLFS so there is a chance that nobody can answer
   your question because every package has its idiosyncrasies and people
   they have to look on sources to find the answer.

Anyway, what happens, if you change the PKG_CONFIG_PATH and make the
/usr/local/lib/pkgconfig, to be the first component, provided that the
installation of pygobject went smoothly under the /usr/local hierarchy
and there is a *.pc file in /usr/local/lib/pkgconfig?

Regards,
Ag.



More information about the lfs-support mailing list