Chapter 6.58. Vim-7.2

Anthony Price elenmar at mailworks.org
Thu Feb 5 09:26:35 PST 2009


05-02-2009

Problem after installing vim

Host system Ubuntu 8.10
Book 6.4
Chapter 6.58. Vim-7.2

After installing Vim (final command vim -c: 'options' vim appears to be 
working fine.

BUT the shell behaves oddly

1. Issuing the command clear does not clear the display; it gives the 
error message 'xterm': unknown terminal type
2. The delete key does not delete but prints the tilde ~ character.

I have tried reinstalling vim, but this has no effect.
I have tried reinstalling bash but this fails with the message: bison -y 
-d ./parse.y
conflicts: 1 shift/reduce
bison: cannot open file `/usr/share/bison/m4sugar/m4sugar.m4': No such 
file or directory
make: *** [y.tab.c] Error 1 "


If I press on (with my dodgy keyboard) I can set up the scripts in ch 7, 
but when I get to the stage of compiling the kernel (ch 8) the make .... 
menuconfig command gives the message: 'Error opening terminal: xterm'

I had this problem with a previous attempt at building LFS and (because 
I wasn't too sure about the build as a whole, I scrapped it and started 
again). This time everything *appeared* to be ok until the problems that 
I have outlined appeared after the installation of vim.

I would appreciate some guidance on this as I don't really want to 
rebuild the whole thing a third time.

Regards,

Anthony.




More information about the lfs-support mailing list