LFS 6.5 Chapter 5 Tcl make *** [install-msgs] Error 139

rhubarbpie at poetworld.net rhubarbpie at poetworld.net
Thu Dec 24 12:14:18 PST 2009


Bruce Dubbs wrote:
> rhubarbpie at poetworld.net wrote:
>   
>> I receive "make *** [install-msgs] Error 139" when compiling Tcl-8.5.7.  
>> I read another user reporting the same error with a suggestion to run 
>> memtest.  Memtest runs without error.
>>
>> I've compiled LFS for years and am attempting to compile 6.5 using my 
>> working 6.3 version.  I don't remember a problem with Tcl with other 
>> versions and see no other errors.  However, I do see "ln: creating 
>> symbolic link 
>> '/lib/tools/bin/../lib/gcc/i686-lfs-linux-gnu/4.4.1/libgcc-eh.a': File 
>> exists" at the end of Gcc Pass2 compilation.  I compiled all Chapter 5 
>> packages as a test and received errors in only Tcl and expect.  I assume 
>> that's predictable as expect relies on Tcl.  Thoughts?
>>     
>
> Did you ensure /tools was empty before you stated the latest build?
>
>    -- Bruce
>   
A long listing of /tools shows only the link to /lfs/tools.

I noticed among tcl, expect, and dejagnu only tcl is a new version.  I 
thought I could perhaps compile my 6.3 tcl as my LFS 6.3 compiled 
successfully.  While the old tcl compiled without error, I received 
"make: *** [expect] Error 1."  So although tcl compiles properly, expect 
blows up.

I changed my tcl commands to reference 8.4.  I changed expect to not 
patch expect -5.43.0-tcl_8.5.5_fix-1.patch.  When that didn't work I 
included that patch for fun even though I had compiled tcl8.4.15.  Same 
thing, Error 1 with expect.



More information about the lfs-support mailing list