Ken Moffat zarniwhoop73 at googlemail.com
Tue Dec 15 11:33:25 PST 2009


2009/12/15 Mike McCarty <Mike.McCarty at sbcglobal.net>:
> William Immendorf wrote:
>> On Tue, Dec 15, 2009 at 7:32 AM, Pixel 73 <pixel73 at hotmail.com> wrote:
>>> I am doing LFS 6.3. Everything went well until Chapter 6.12, GCC-4.1.2. When
>> Please don't use LFS 6.3, unless your host system is old enough to
>> build it. I recommend LFS 6.5 from now on.
>
> This comment doesn't even make sense to me. Just how old does
> a system need to be in order to build LFS 6.3? Every machine
> I own predates LFS 6.3. What "young" machine is incapable of
> building it?
>
> To the OP: Build whatever version you want, and run whatever
> version you want.
>
> LFS Motto: My Machine, My Rules
>
> Right?
>
> Mike
> --

Right (for My Machine, My Rules), but historically we've seen
problems when people try to use newer toolchains than are
in the book (i.e. build failures).

In general, it's very hard to recommend that anyone use an
LFS book older than the latest release.  For BLFS, at least for
those desktop packages which are in BLFS, the development
book is often far more up to date (although, at the moment,
it probably still has a lot that hasn't changed since the 6.3
release).

ĸen
-- 
After tragedy, and farce, "OMG poneys!"



More information about the lfs-support mailing list