Version 6.5 - 6.15.1 GCC compile failure

Justin Mattock justinmattock at
Wed Dec 2 15:39:20 PST 2009

On Wed, Dec 2, 2009 at 3:35 PM, Sean Porterfield
<linuxfromscratch at> wrote:
>> Sean Porterfield wrote:
>>> After compiling and installing gcc, I tried to compile dummy.c but it
>>> failed.  Any suggestions on how to figure out where I screwed up?
>> From: Doug Downham
>> In section 6.10, using version 6.5 of the LFS book, I've encountered a
>> strange error.
>> When I create dummy.c and run 'cc dummy.c -v -Wl, --verbose &>
>> dummy.log', a.out is not produced.  dummy.log says
>> "/tools/lib/gcc/i686-pc-linux-gnu/4.4.1/../../../../i686-pc-linux-gnu/bin/ld:
>> : No such file: No such file or directory".
> Well...  Seeing as that's the same error message, I checked my `cc`
> command.  Lo and behold, I keyed that same mystery space in.  I removed
> the space, and all is well.  Onward and upward!  Thanks for everyone's
> help on this.
> --
> Sean Porterfield
> --
> FAQ:
> Unsubscribe: See the above information page

amazingly space like this does make a difference
i.e. in SELinux refpolicy(build.conf) I did something
like that, and it caused a build error.
(ran around for weeks going crazy);

Justin P. Mattock

More information about the lfs-support mailing list