LFS-6.3 can't boot

Scott Castaline hscast at charter.net
Thu Sep 25 18:39:02 PDT 2008


Adam Roach wrote:
> Scott Castaline wrote:
>> Completed the build using Virtualbox virtual machine. On the first boot 
>> I get the following:
>>
>> 	Booting 'LFS 6.3
>>
>> root (hd0,0)
>>   Filesystem type is ext2fs, partition type 0x83
>> kernel /boot/lfskernel-2.6.22.5 root=/dev/hda3
>>
>> Error 15: File not found
>>
>> Press any key to continue...
>>
>>
>> menu.lst is as follows:
>>
>> title LFS 6.3
>> root (hd0,0)
>> kernel /boot/lfskernel-2.6.22.5 root=/dev/hda3
>>
>>
>> my partitions are:
>>
>> /dev/hda1 = /boot
>> /dev/hda2 = swap
>> /dev/hda3 = /
>>
>> stage 1, 1_5, 2 are installed in /boot/grub
>> lfskernel-2.6.22.5, System.map-2.6.22.5, & config-2.6.22.5 are installed 
>> in /boot.
>>
>> I had this before and tried reinstalling grub and the kernel with no 
>> luck, so I started from scratch again thinking that I missed a step, but 
>> I'm sure that none were missed.
>>   
> If hda1 is your boot partition, make sure that change the kernel line to 
> "kernel /lfskernel-2.6.22.5 root=/dev/hda3". /boot would refer to your 
> boot partition after it was mounted on /boot from your hda3 partition.
> 
> 
I'm not sure what you are saying. I do have root=/dev/hda3 on the kernel 
command. The root command points to the boot partition using grubs 
naming/numbering of the devices, so what linux sees as /dev/hda1 grub 
sees as hd0,0 (disk 0, part 0).



More information about the lfs-support mailing list