locales issues

Juan A. Moreno jamc60 at gmail.com
Wed Oct 29 11:57:46 PDT 2008


On Wednesday 29 October 2008 18:21:17 Manuel Gonzalez Montoya wrote:
> On Tue, Oct 28, 2008 at 11:18 AM, Juan A. Moreno <jamc60 at gmail.com> wrote:
> > Hi
> > I'm trying to put the console in Unicode mode following the instructions
> > from chapter 7.6 in the LFS book svn version. I'm a spanish native
> > speaker and this is my /etc/sysconfig/console file:
> >
> > # Begin /etc/sysconfig/console
> >
> > UNICODE="1"
> > KEYMAP="es"
> > KEYMAP_CORRECTIONS="euro2"
> > LEGACY_CHARSET="iso-8859-15"
> > FONT="lat9w-16 -m 8859-15"
> >
> > # End /etc/sysconfig/console
> >
> > I get correctly the 'euro' symbol and the ñ (ntilde) in the console but
> > when I try to get accents with the dead keys of my 'es' keyboard I get
> > -'a- instead of -á-.
> > The same with é, í, ó, ú.
> >
> > It's possible to  obtain the spanish accents in the current version of
> > LFS?
> >
> > --
> > http://linuxfromscratch.org/mailman/listinfo/lfs-support
> > FAQ: http://www.linuxfromscratch.org/lfs/faq.html
> > Unsubscribe: See the above information page
>
> I'm using KEYMAP="la-latin1" in /etc/sysconfig/console and it works
> without problem for the accented vowels, but I'm not sure about the
> euro symbol.

I have found a solution. At the end of the console boot script the dead keys 
are disabled due a kernel bug. At least in the previous version of 
lfs-bootscrips. I dont have tried the current version  20081023.

Well, if I add BROKEN_CONSOLE=false in /etc/sysconfig/console, the vowels 
accented work fine. Also i get correctly the euro symbol and the ñ.
I havent needed the patch for the kernel.

My /etc/sysconfig/console now:

# Begin /etc/sysconfig/console

UNICODE="1"
KEYMAP="es"
KEYMAP_CORRECTIONS="euro2"
LEGACY_CHARSET="iso-8859-15"
BROKEN_COMPOSE=false
FONT="lat0-16 -m 8859-15"

# End /etc/sysconfig/console




More information about the lfs-support mailing list