Cannot boot into LFS, No NFS server available.

Michael Brandstetter listen at
Thu Oct 16 05:39:01 PDT 2008

Am Donnerstag, 16. Oktober 2008 14:01:06 schrieb Brittany Dunlap:

Hello Brittany!

> No matter what I do to edit menu.lst I cannot get rid of these errors
> while booting into LFS.
> Cannot open root device sda3...
> Please append a correct "root=" boot option...
> No NFS server available.
> It then tries to make me boot from a root floppy. Hitting enter causes
> kernel panic.
> The options it gives are "0300" "4194302" "hda" "driver: ide-cdrom"
> I tried changing root to hda instead of /dev/sda3 and still got the
> same error.
> Attached is my menu.lst.

kernel          /boot/lfskernel- root=(hd0,2) ro

That line should be:
for ide
kernel          /boot/lfskernel- root=/dev/hda3
or if you have a scsi drive
kernel          /boot/lfskernel- root=/dev/sda3

> Thanks in advance,
> Brittany Dunlap
> #lfs-support > bdunlap

regards Michael
OSS e.V.
Duisburger Linux User Group
Free Software Foundation Europe

  /"\        ASCII Ribbon Campaign
  \ /        No HTML/RTF in email
   x         No Word docs in email
  / \        Respect for open standards

More information about the lfs-support mailing list