LFS 6.3 chpt 5.7 step cmd problem

Stealth genericmaillists at gmail.com
Sun Nov 30 09:46:50 PST 2008

When I finished the build of glibc I was still 
in /mnt/lfs/sources/glibc-build.

I ran:

mv -v /tools/bin/{ld,ld-old}
mv -v /tools/$(gcc -dumpmachine)/bin/{ld,ld-old}
mv -v /tools/bin/{ld-new,ld}
ln -sv /tools/bin/ld /tools/$(gcc -dumpmachine)/bin/ld

then I ran:

gcc -dumpspecs | sed 's@^/lib/ld-linux.so.2@/tools&@g' \
  > `dirname $(gcc -print-libgcc-file-name)`/specs

and I get:

sed: can't read /usr/lib/gcc/i486-pc-linux-gnu/4.1.2/specs: No such 
file or directory

Obviously the i486 part is wrong because it should be i686. Also why 
is it looking in /usr/lib when the search and replace string tells 
it to look in /lib at the starting point of the search string?

I tried moving around to different directories to see if the cmd 
works but the same message no matter where I am in the file 

I have to assume I missed a step some where before. I have no idea 
what or where.

I have not attempted to go passed this point.

I have followed everything by the book except, I decided to use 
kernel (this was the newest when I downloaded it) instead 
of .

Did I cause my problem by using the newer kernel?


More information about the lfs-support mailing list