kernel configuration and installation

Ken Moffat ken at linuxfromscratch.org
Sat Nov 1 12:42:01 PDT 2008


On Sat, Nov 01, 2008 at 05:49:52PM +0100, Wolfgang Messingschlager wrote:
> Ken Moffat wrote:
> >>
> >  That implies you are using LFS-6.2.  I'm afraid I think glibc-2.3.6
> > is now regarded as "very old".
> > 
> >  I don't know what to recommend - LFS-6.3 is about to become "old",
> > hopefully within the next 3 weeks, but as I said in a different
> > thread I expect there to be a *lot* of breakage with the package
> > versions currently in BLFS.  Meanwhile, I see that you've just
> > reached the final stage of your build :-(
> > 
> > ĸen
> 
> Hi Ken,
> 
> 
> I am now in the middle of chapter 8 and I have now the problem to build 
> a kernel which doesn't need a initrd file. I got a hint from Dan 
> Nicholson to use
> CONFIG_IDE_GENERIC=y
> 
> I am now recompiling the kernel and I want to check if that works.
> 
> But I am now surprised the point you write about BLFS. Do you suggest to 
> have LFS-6.3 in order to use it or do you suggest make a new LFS within 
> the next 3 weeks?
> 
 I'm not quite sure what you are asking, and as I said, for people
using LFS-6.2 I don't *know* what to recommend.

 If you are building LFS-6.3, the packages in BLFS-6.3 should work
fine (they will be old, but still usable - I sometimes still use a
6.3 box, the only updates I've made to it are a newer gimp and ufraw
and the latest firefox2).

 If you are using current LFS-dev (which will become 6.4 later this
month, all being well) I expect you will find a lot of breakage.  I
posted on blfs-dev a pointer to a summary of my own experimentation:
http://www.linuxfromscratch.org/~ken/new-desktop-late-2008-first-attempt.gz
 - very much E.O.E. (Errors & Omissions Excepted, in other words
it's bound to contain mistakes.)

 At the moment I'm still working through my "action points"
before my next attempt (right now, I'm swearing at xulrunner ;).

 I don't say my choice of packages and options is correct, or
generally useful, but nearly everything has moved on a lot from what
is in BLFS-6.3.  In particular, if you want to use new versions of
applications you will need to use new versions of dependencies (e.g.
newer cairo and lcms for firefox3).

 Mostly, new versions should just drop in and solve compile
failures, but sometimes they bring new dependencies (e.g.
gnome-keyring acquired a dependency on libtasn1 a couple of gnome
releases ago), and gdm is now 'unattractive' to me.  Occasionally
things drop out (libgtkhtml, at least for what I'm building).

 If you are a kde user, the changes for kde4 are considerably more
than the general churn in other places - I've now found I'm unhappy
with my build of cmake (it's using its own versions of libraries,
that wasn't obvious to me) and Qt (various junk in /usr).  I've no
idea what the dependencies are for things like kmail.  There was a
fix on -dev the other day for building kde-3.5.10, so even the
"old" kde is affected by change.

ĸen
-- 
das eine Mal als Tragödie, das andere Mal als Farce



More information about the lfs-support mailing list