LFS 6.3 - 6.23. Perl-5.8.8 - Error during "make" of "Making IPC::SysV (dynamic)"

Søren Tauber Lassen stl at athena.dk
Thu Jul 24 00:07:54 PDT 2008


I've reached a point in building LFS 6.3, where I'm in need of help.
I'm using the LFS 6.3 Live CD as a base for building my LFS system.
I use all the packages recommended by the 6.3 book, although I've tried with both linux- (recommended minimum) and latest linux-2.6.26.

During the compilation of the Perl-5.8.8 package, an error occurs and I cannot find a solution.
It runs as far as the part of "Making IPC::SysV (dynamic)", but at the end, it fails with an error.

        Making IPC::SysV (dynamic)
Checking if your kit is complete...
Looks good
Writing Makefile for IPC::SysV
make[2]: Entering directory `/sources/perl-5.8.8/ext/IPC/SysV'
make[2]: Leaving directory `/sources/perl-5.8.8/ext/IPC/SysV'
make[2]: Entering directory `/sources/perl-5.8.8/ext/IPC/SysV'
cp Msg.pm ../../../lib/IPC/Msg.pm
cp Semaphore.pm ../../../lib/IPC/Semaphore.pm
cp SysV.pm ../../../lib/IPC/SysV.pm
../../../miniperl "-I../../../lib" "-I../../../lib" ../../../lib/ExtUtils/xsubpp  -typemap ../../../lib/ExtUtils/typemap  SysV.xs > SysV.xsc && mv SysV.xsc SysV.c
cc -c   -fno-strict-aliasing -pipe -Wdeclaration-after-statement -I/usr/local/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -O2   -DVERSION=\"1.04\" -DXS_VERSION=\"1.04\" -fpic "-I../../.."   SysV.c
SysV.xs:7:25: error: asm/page.h: No such file or directory
make[1]: *** [SysV.o] Error 1
make[1]: Leaving directory `/sources/perl-5.8.8/IPC/SysV'
make: *** [lib/auto/IPC/SysV/SysV.so] Error 2

At this point the compilation ends. As far as I can see, there are still a number of packages to be build after this point.
I've compared my build with the build-logs on the LFS web-site. Up to the point of failure, there are no real differences and everything looks as it is supposed to.

I went back and checked previous package builds against available build-logs and found no errors there.
I've checked and re-checked that I wasn't missing some package or step along the way. I've even redone the entire LFS build from scratch twice, being meticulous about every step of the way.

I've tried to ignore the compilation error and continue, but then other packages later on won't compile.
Searching for the "page.h" locates it in folder:


I'd appreciate any help I can get.

// Soeren

More information about the lfs-support mailing list