Compile error after final Re-adjusting the Toolchain

Tarsier tarsier6 at yahoo.com
Sun Jul 13 22:32:32 PDT 2008


--- On Mon, 7/14/08, Chris Staub <chris at beaker67.com> wrote:

> From: Chris Staub <chris at beaker67.com>
> Subject: Re: Compile error after final Re-adjusting the Toolchain
> To: tarsier6 at yahoo.com, "LFS Support List" <lfs-support at linuxfromscratch.org>
> Date: Monday, July 14, 2008, 12:39 PM
> Tarsier wrote:
> >>  The big problem here is the gcc version Tarsier
> is using -
> >> it doesn't match what's in the book.  I
> know people
> >> are using the
> >> 4.3 series, but I don't know what changes
> they've
> >> had to make.
> >>
> >>  Trying newer versions, after one is familiar with
> the
> >> build process,
> >> is not a bad thing.  However, expecting to use a
> new
> >> version of gcc
> >> (rather than a new point release) without the
> instructions
> >> changing,
> >> is "optimistic".  And asking for help
> without
> >> mentioning the
> >> variation(s) one has made doesn't help
> anybody.
> >>
> > 
> > I'm experienced with LFS building. I'm trying
> as per LFS version SVN-20080711. No instruction were
> changed for compiler building.
> > 
> > Tarsier
> > 
> > 
> >       
> That can't be. Using GCC 4.3 with dev LFS simply
> isn't possible without 
> somehow deviating from the current instructions. For
> starters, 4.3 
> requires GMP and MPFR, which are NOT installed anywhere in
> LFS...
> -- 

Oh, what I mean is GCC-4.2.3 - Pass 1 and GCC-4.2.3 - Pass 2 instructions. All necessary dependencies installed.

Tarsier


      




More information about the lfs-support mailing list