Kernel panic... Unable to mount root fs

Spahn, Daniel dspahn at cuh2a.com
Tue Jul 1 10:15:21 PDT 2008



>Hi all, hope someone can help me out, it's been five years since I last
used LFS (or linux for that matter!) so I'm a bit rusty...

>I've gone through the LFS6.3 book. It all seems to go fine until I boot
up the new system. These are the last three lines before it totally
freezes:

>List of all partitions:
>No file system could mount root, tried:
>Kernel panic - not syncing: VFS: Unable to mount root fs on
unknown-block(0,0)

>So what's going on? I've looked through the FAQ and the mailing-list
archive. These suggest that I need to enable SCSI support when compiling
the >kernel (in the Ubuntu 7.xx distro I'm using as a host, my hard
drive is sda not hda). Well I'm pretty sure I've done that!

>Tried compiling a 'vanilla' kernel, ie left everything alone in
menuconfig - didn't work.
>Tried ticking a few options in menuconfig with the letters 'scsi' in
them - didn't work... but there are so damn many, what *exactly* am I
supposed >to be enabling?
>Tried using the .config from the Ubuntu distro... didn't work.
>Tried plopping the kernel from the Ubuntu distro straight into the
/boot of the LFS partition... didn't work.
>Burned an LFS LiveCD, booted that up. It found my hard drive fine.
Nicked the config file off that, compiled the kernel... didn't work.

>I'm out of ideas!

Did you compile support for your filesystems? Did you lspci your
hardware and compile in support for your hard drive? You may have a
nonstandard drive that needs to have certain kernel options enabled.


      __________________________________________________________
Not happy with your email address?.
Get the one you really want - millions of new email addresses available
now at Yahoo! http://uk.docs.yahoo.com/ymail/new.html
-- 
http://linuxfromscratch.org/mailman/listinfo/lfs-support
FAQ: http://www.linuxfromscratch.org/lfs/faq.html
Unsubscribe: See the above information page



More information about the lfs-support mailing list