Fallen at the last fence.

martin welsh martin at mhwelsh.force9.co.uk
Wed Jan 30 11:43:50 PST 2008


Xandros 4.1 OS, AMD64 SATA disks.
menu.1st  -

# By default boot the first menu entry.
default 0

# Allow 30 seconds before booting the default.
timeout 30

# Use prettier colors.
color green/black light-green/black

# The first entry is for LFS.
title LFS 6.3
root (hd0,6)
kernel /boot/lfskernel-2.6.22.5 root=/dev/sda7

"
/mnt/lfs is situated on/dev/sda7

The following text is displayed when loading comes to a halt.

Root - NFS: No NFS server available , giving up.
VFS: unable to mount root fs via NFS trying floppy
VFS: insert root floppy and press enter

Floppy inserted, return.

List of all partitions:
0200      1440 fd0 (driver?)
0300    4194302 hda driver: ide-cdrom
0340    4194302 hdb driver: ide-cdrom
No filesystem could mount root, tried: reiserfs ext3 ext2 msdos vfat iso9660
Kernel panic - not syncing: VFS: Unable to mount root fs on 
unknown-block(2,0).

Starting the machine with the root floppy provides the following data;

root (hd0,6)
Filesystem type is ex2fs, partition type 0x83
setup (hd0)
Checking if "/boot/grub/stage1" exists  ... yes
Checking if "/boot/grub/stage2" exists  ... yes
Checking if "/boot/grub/e2fs_stage1_5" exists  ... yes
Running "embed /boot/grube2fs_stage1_5 (hd0)"  ... 15 sectors are embedded.
suceeded
Running "install /boot/grub/stage1 (hd0) (hd0)1+15 p 
(hd0,6)/boot/grub/stage2 /boot/grub/menu.lst" ... succeded
Done.

I am at a loss.  The grub boot loader says the system is unworkable but 
the response from the floppy triggering an unloaded machine says that 
there is nothing wrong with the boot loader or the relevant file structures.

Are there any checks that I can carry out on the build to confirm that 
it is healthy?
Have I wrongly called the hard disc /dev/hda7, as it is referred to in 
the build?


martin welsh



More information about the lfs-support mailing list