compilation error for inetutils-1.5 in LFS-6.3

Justin O'Neil oneil.justin at
Sun Jan 27 21:20:37 PST 2008

Hello.  I'm building an LFS 6.3.  This is my first LFS (well, not really,
I tried building one a couple years ago, but I was a total Linux newbie
back then so I didn't get very far).  I'm now stuck at the inetutils-1.5
compilation section in Chapter 6.
Here is what I tried to get it working:
 *It looks from the log (attached) that the problem is with telnet/telnet.c
  - specifically it seems that it's trying to use `tgetent'
*I used the info pages to determine that `tgetent' is a function from
*I grep'ed telnet.c for '#include' and found that term.h was not being
 included, so I edited telnet.c to include it (a new source tree of course).
*After trying the make command again, I found that it was failing at the
 same spot, for the same reason, therefore my change had no effect

If someone could offer insight, I would appreciate it.
Another thing I should probably mention is that through Chapter 6, when I
installed packages, I first faked the installation to another directory,
tar'ed and bzip2'ed the directory, and extracted it in the root directory to
complete the installation.  I usually used the DESTDIR option, except when it
wasn't available, then I found another way to do it.

Thank You
-------------- next part --------------
A non-text attachment was scrubbed...
Name: makelog.log
Type: application/octet-stream
Size: 16165 bytes
Desc: not available
URL: <>

More information about the lfs-support mailing list