LFS 6 System Won't Boot

Dan Nicholson dbn.lists at gmail.com
Sat Jan 26 11:17:52 PST 2008

On Jan 26, 2008 11:00 AM, Mark Olbert <molbert at iterobiopharm.com> wrote:
> 2) I put some echo statements in /etc/rc.d/init.d/rc to watch what was happening. After running the last script in /etc/rc.d/rcsysinit.d it exists normally. But I also had it display the running processes before it exited (via ps ax), and I noticed that I have two init processes running. Here's a snip:
> 1        ?        ?                0:00    init boot
> ...
> 973    ?        Ss+          0:00    init boot
> 976    ?        S+            0:00    /bin/sh /etc/rc.d/init.d/rc sysinit
> I don't no much at all about init, but it seems odd to me that I have two copies of it running. Then again, maybe it just spawns processes to do its work.

Hmm, we'll I don't actually know exactly how init works either. But I
suppose that it's reasonable the 973 is a fork of 1 which then runs
the commands. You could change that ps command to "ps -ef" and see
what the PPID of all the process is.

> 3) My kernel and udev are 2.6.10 and 030 (I think; at least, the source file on the system, which I think is the same one that I used when I built the LFS system years ago, is udev-030.tar.bz2 (I may have the file extensions wrong, but that's not important).

An old udev. Well, what I said before about he about udev and sd*
might not be entirely accurate. But I still believe it's the kernel
telling udev to create sd* devices and all the rules ever did was set
ownership and permissions on the device.

> Regarding your comment about the udev rules and the kernel, is there a way to configure udev to have it log what it's told by the kernel? All I can tell you is that the config file I saw when I first encountered this problem did not have any entries for hd and sd and no sd nodes got created (there was an hdb node created, I think, for  the DVD drive). After I added the Slackware rules (and some associated scripts) it had those rules and the nodes got created.

In newer udev, you would change to udev_log="debug" in
/etc/udev/udev.conf. I don't know how long that's been the case, but
the udev man page should tell you.

> I tried downloading the udev rules from an LFS archive from around the time I built the system (that downloaded file had hd and sd rules in it). But no sda nodes got created with that file (I don't know why). Here's the section from the LFS archives (udev-config-4.rules, LFS v6.1.1):
> # Storage/memory devices
> KERNEL=="fd[0-9]*",                 GROUP="floppy"
> KERNEL=="ram[0-9]*",                GROUP="disk"
> KERNEL=="raw[0-9]*", NAME="raw/%k", GROUP="disk"
> KERNEL=="hd*",                      GROUP="disk"
> KERNEL=="sd[a-z]",                  GROUP="disk"
> KERNEL=="sd[a-z][0-9]*",            GROUP="disk"
> KERNEL=="sd[a-i][a-z]",             GROUP="disk"
> KERNEL=="sd[a-i][a-z][0-9]*",       GROUP="disk"
> KERNEL=="s[grt][0-9]*",             GROUP="disk"
> KERNEL=="scd[0-9]*",                GROUP="cdrom"
> KERNEL=="dasd[0-9]*",               GROUP="disk"
> KERNEL=="ataraid[0-9]*",            GROUP="disk"
> KERNEL=="loop[0-9]*",               GROUP="disk"
> KERNEL=="md[0-9]*",                 GROUP="disk"
> KERNEL=="dm-*",                     GROUP="disk",   MODE="0640"
> KERNEL=="ht[0-9]*",                 GROUP="tape"
> KERNEL=="nht[0-9]*",                GROUP="tape"
> KERNEL=="pt[0-9]*",                 GROUP="tape"
> KERNEL=="npt[0-9]*",                GROUP="tape"
> KERNEL=="st[0-9]*",                 GROUP="tape"
> KERNEL=="nst[0-9]*",                GROUP="tape"
> KERNEL=="iseries/vcd*",             GROUP="disk"
> KERNEL=="iseries/vd*",              GROUP="disk"

Yeah, all any of those rules are doing is setting the group. But, if
you removed them, you'd still get the devices, just with root:root
ownership. I guess it'd be interesting to know what's in the slackware


More information about the lfs-support mailing list