lfs installation issue

Ken Moffat ken at linuxfromscratch.org
Mon Aug 25 10:27:11 PDT 2008


On Mon, Aug 25, 2008 at 12:10:51PM -0400, Satish Patel wrote:
> my hostreq output is this
> 
> root at piyu-desktop:~# sh version-check.sh
> bash, version 3.2.25(1)-release
> Binutils: (GNU Binutils
> bison (GNU Bison) 2.3
> bzip2,  Version 1.0.4, 20-Dec-2006.
> Coreutils:  5.97
> diff (GNU diffutils) 2.8.1
> GNU find version 4.2.31
> GNU Awk 3.1.5
> gcc (GCC) 4.1.3 20070929 (prerelease) (Ubuntu 4.1.2-16ubuntu2)
> GNU C Library stable release version 2.6.1,
> grep (GNU grep) 2.5.1
> gzip 1.3.12
> Linux version 2.6.22-14-generic (buildd at palmer) (gcc version 4.1.3  
> 20070929 (prerelease) (Ubuntu 4.1.2-16ubuntu2)) #1 SMP Sun Oct 14  
> 23:05:12 GMT 2007
> GNU Make 3.81
> patch 2.5.9
> GNU sed version 4.1.5
> tar (GNU tar) 1.18
> 
> 
> kindy tell me what change i have to do.
> 

 Those look reasonable.  In particular, you are using gawk ("GNU Awk
3.1.5") and your kernel is a variant of 2.6.22.14 compiled with the
system compiler (a prerelease version of gcc-4.1.3).

 The only "oddity" is your binutils - it's probably a new version
which presents the information in a different format.  You might
want to look at the whole output from 'ld --version', but AFAIK
there haven't been any issues with recent versions of binutils on
the x86 architecture.

 Previously, you wrote:
> Linux Kernel-2.6.x  (having been compiled with GCC-3.0 or greater)
> 
> i dont understand it ?

 We can see that your kernel is indeed from the 2.6 series with a
suitable compiler.  The reason for that requirement was that people
sometimes tried to build from a host running a 2.4 kernel, and for
2.4 kernels the recommended compiler was gcc-2.95.3 - that is no
longer supported by the 2.6 kernel source.

ĸen
-- 
das eine Mal als Tragödie, das andere Mal als Farce



More information about the lfs-support mailing list