grub hangs without error message on mac mini

Richard Melville richard.melville at ntlworld.com
Tue Apr 29 02:38:31 PDT 2008


>
> I've just installed LFS SVN-20080423 on a new Mac Mini (Intel) but the 
> computer doesn't start (no OSX, only one partition for Linux). All I see 
> is:
>
>  GRUB Loading stage1.5.
>  
>  
>  GRUB loading, please wait...
>
>
> There is no error message, nothing. I'm a little bit puzzled, as this is 
> not the first LFS system I install, but the first time I don't know what 
> to do.
>
> I use grub-0.97 with the disk_geometry and the 256byte_inode patches 
> from the development page.
>
>
> The partition to boot from is /dev/sda1 and in my grub menu is
>
>  default 0
>  timeout 10
>  title LFS
>  root (hd0,0)
>  kernel /boot/lfskernel root=/dev/sda1
>
> The file does exist and I installed grub in the grub shell with "root 
> (hd0,0)" and "setup (hd0)".
>
>
> Just to make sure, I installed ubuntu (7.04) on the very same computer 
> (they use grub too) and the system starts, without problem. So the Mac 
> Mini does start some Linux with grub, it's just my installation. I have 
> a MacBook running with LFS and grub, I think this is some similar 
> hardware and there isn't a problem either.
>
>
> So, why is grub hanging there (I rebooted after 10 minutes)? What might 
> I do to solve the problem? What is grub waiting for?
>
>
> Thanks for any help,
> Andreas
>
>   
Just a thought - have you copied over to the /boot/grub/ directory the
correct 1.5 file in relation to the file system that you are using. 
They are all file system specific.

Richard Melville



More information about the lfs-support mailing list