Flex-2.5.34

Ken Moffat ken at linuxfromscratch.org
Mon Apr 7 06:56:46 PDT 2008


On Mon, Apr 07, 2008 at 12:56:52PM +0200, Nicolas FRANCOIS wrote:
> Hi.
> 
> The flex version present in the SVN LFS book has some compatibility
> problem with old lex. Or, to be more precise (if I understood the message
> I wrote clearly), the previous versions of flex did not halt on
> incompatible options of lex, while the 2.5.34 version produces an error.
> 
> Some examples of packages which don't appreciate the change are
> tetex-3.0, and lm_sensors (both version 2 and version 3).
> 
 And I put patches for those (well lm_sensors_2.10.4, I hadn't heard
of version 3, as well as libIDL and libpcap) in the patches repo -
AFAIK everything current can be compiled, so the version in the book
is usable.

> I think version 2.5.35 partly solves the issue. So one should upgrade,
> shouldn't one ?
> 
> \bye
> 
 My reading of the problem was that old versions of flex used to
silently ignore the lex options, and 2.5.34 decided to choke.  I
_hope_ that 2.5.35 fixes this (the maintainer seems to think it
does), but I haven't used it yet and I'm not likely to be using it
any time soon.  I'm more likely to pick up Randy's suggested seds
for the testsuite with 2.5.34 (which does indeed mostly run, although
I thought it didn't), but again that is way down my list of things to
do.

 If you decide to use 2.5.35, please report your successes or
failures with it in trac so that whoever eventually picks it up will
know if any further action is needed.  Thanks.

ĸen
-- 
das eine Mal als Tragödie, das andere Mal als Farce



More information about the lfs-support mailing list