glibc-2.5.1 compile error

Joseph M. yosyp.list at gmail.com
Sun Sep 30 14:39:26 PDT 2007


I am using the stable book (6.3), when doing whats in chapter 5.6,
"Installing Glibc", I get the following error:
../nptl/sysdeps/i386/i686/../tls.h:66:3: error: #error "TLS support is
required."
make[2]: *** [/mnt/lfs/sources/intl/bindtextdom.o] Error 1
make[2]: Leaving directory `/mnt/lfs/glibc-2.5.1/intl'
make[1]: *** [intl/subdir_lib] Error 2
make[1]: Leaving directory `/mnt/lfs/glibc-2.5.1'
make: *** [all] Error 2

Ran configure as,
(Also tried adding --with-tls , no results):
../glibc-2.5.1/configure --prefix=/tools \
    --disable-profile --enable-add-ons \
    --enable-kernel=2.6.0 --with-binutils=/tools/bin \
    --without-gd --with-headers=/tools/include \
    --without-selinux



The host system is (Slackware 12.0):
Linux server 2.6.21.5-smp #2 SMP Tue Jun 19 14:58:11 CDT 2007 i686
Intel(R) Celeron(R) CPU 2.80GHz GenuineIntel GNU/Linux

/lib/libc.so.6 has Thread-local storage support included.
make version is 3.81



More information about the lfs-support mailing list