Adjusting the toolchain: specs file

Dan Nicholson dbn.lists at
Tue Sep 25 10:04:28 PDT 2007

On 9/25/07, Richard Caldwell <rcaldwellie at> wrote:
> Hi,
>     I'm using lfs6.3 livecd an in section 5.7 Adjusting the toolchain, the 'gcc -dumpspecs .............' command doesn't appear to run properly. I've tried finding the "specs" file to verify that its been edited correctly but I can't find it.
> >From other posts I think the specs file should be found at
> /usr/lib/gcc/i486-pc-linux-gnu/4.1.2/
> but theres no file called specs at that location? I've also tried find on both the host an $LFS but not found it? Everything seemed to work ok up to this point but there seems to be something wrong?
> Can anyone shed any light on this?

Maybe you don't have PATH set correctly? gcc should be /tools/bin/gcc
at that point, meaning `gcc -print-libgcc-file-name' should print
something like /tools/lib/gcc/i686-pc-linux-gnu/4.1.2/libgcc.a. Also,
there shouldn't be a specs file there unless you've created it. The
reason `gcc -dumpspecs' is used is so that we edit the builtin


More information about the lfs-support mailing list