LFS/Busybox and user/group problem !

JBLinux jblinux at orange.fr
Thu Sep 20 05:38:17 PDT 2007




> Message du 20/09/07 14:05
> De : "Spahn, Daniel" <dspahn at cuh2a.com>
> A : "JBLinux" <jblinux at orange.fr>, "LFS Support List" <lfs-support at linuxfromscratch.org>
> Copie à : 
> Objet : RE: LFS/Busybox and user/group problem !
> 
> 
> 
> -----Original Message-----
> From: lfs-support-bounces at linuxfromscratch.org
> [mailto:lfs-support-bounces at linuxfromscratch.org] On Behalf Of JBLinux
> Sent: Thursday, September 20, 2007 4:44 AM
> To: lfs-support at linuxfromscratch.org
> Subject: LFS/Busybox and user/group problem !
> 
> Hi all.
>    I'm building a LiveCD based on kernel 2.6.20, busybox 1.6.0 and other
> tools that I need.
>    My first step was to build a basic LiveCD : a bootable CD using Grub,
> the kernel 2.6 and busybox.
>    
>    With busybox 2.6.0 all work great EXCEPT a problem using user/group.
> The following commands don't work correctly :
>     # touch toto
>     # chgrp bin toto
>     chgrp: unknown group name: bin
>    
>    But the grou bin exist in /etc/group :
>    # more /etc/group
>    root::0:root
>    bin::1:
>    rpm::2:
>    
>    I've look around my config fils in /etc (/etc/passwd, /etc/group,
> /etc/shadow and /etc/nsswitch.conf) but all seem ok !
>    Content is above :
>      # more /etc/group
>      root::0:root
>      bin::1:
>      rpm::2:
>    
>      # more /etc/shadow
>      root:?????:12439:0:99999:7:::
>    
>      # more /etc/passwd
>      root:x:0:0:root:/root:/bin/bash
>  
>    I've tried with the recent 1.7.1 busybox and it seem to work (the
> chgrp work correctly).
>    
>    BUT !!!!!!!!!!!!!!!!!!!!!!!!!!!!!
>    
>    I've the RPM tool in my binaries (I don't use the busybox rpm version
> coz I need all option of RPM) and here, for a package that need group
> bin, RPM say me that group bin doesn't exist !!!!!!!!!!!!!
>    Damned !
>    
>    # rpm -Uvh --nodeps expat-2.0.0-1.i386.rpm
>    warning: group bin doesn't exist  - using root
>    
>    
>    Anybody have an idea where I can look ?
>    I'm unable to find a way to solve this !
>    For a complementary information, after my boot process, I'm directly
> conected in root account. A problem of initab that can imply the rest ?
> 
> Thx for your help !
> JB
> 
> Just a thought, but are you booted or chrooted into the system whose
> /etc/group you are viewing? Has your environment been sourced? How was
> bin added to /etc/groups?
> -- 
> http://linuxfromscratch.org/mailman/listinfo/lfs-support
> FAQ: http://www.linuxfromscratch.org/lfs/faq.html
> Unsubscribe: See the above information page
> 
> 

I've prepared all my /etc files by chrooting in my LFS.
I've tested the LiveCD by booting the ISO and I've check the content of /etc/{passwd,group,shadow,gshadow} that are like i've done in my chroot env !
bin group was added by writing a new entry in the /etc/group and /etc/gshadow files.







More information about the lfs-support mailing list