configure: error: Need linker with .init_array/.fini_array support.

Alec Wright alecjw at gmail.com
Sun Sep 16 06:03:17 PDT 2007


When doing the configure script for glibc (pass 1) in LFS 6.3, i get the
error:
configure: error: Need linker with .init_array/.fini_array support.

And earlier on:
*** WARNING: You should not compile GNU libc without versioning. Not
using
*** versioning will introduce incompatibilities so that old binaries
*** will not run anymore.
*** For versioning you need recent binutils (binutils-2.8.1.0.23 or
newer).

I am using newer versions of glibc and binutils than recommended, could
that be the problem?




More information about the lfs-support mailing list