unrecognised option `-mtune=pentiumpro`

Spahn, Daniel dspahn at cuh2a.com
Sat Sep 15 18:58:52 PDT 2007

-----Original Message-----
From: lfs-support-bounces at linuxfromscratch.org on behalf of Richard Caldwell
Sent: Sat 9/15/2007 5:11 PM
To: lfs-support at linuxfromscratch.org
Subject: gcc:unrecognised option `-mtune=pentiumpro`
    in 5.7 Adjusting the Toolchain when I run:
gcc -dumpspecs | sed 's@^/lib/ld-linux.so.2@/tools&@g' \
> `dirname $(gcc -print-libgcc-file-name)`/specs

I got the message "gcc:unrecognised option `-mtune=pentiumpro` "
I copied and paste the command from the manual so I know I entered 
it correctly. Cant find anything relevant in the archives. This was the only
output to screen and as I read somewhere sed should output every line 
processed to the console, so I would have expected some other output if 
the command did anything. Does it look like the command failed?
When I ran it again it didn't even give the error message?
Where is the specs file that I'm meant to check for the changes?

(sorry for resending but added a more meaningful title!)
FAQ: http://www.linuxfromscratch.org/lfs/faq.html
Unsubscribe: See the above information page

What distro are you building from? I recommend using the LFS liveCD.

More information about the lfs-support mailing list