Compilation of ncurses (chapter 5) with gpm

support support at cslimits.net
Tue Sep 11 07:37:07 PDT 2007


Nicolas, 

I'm not having a problem w builing ncurses in ch 5 or 6; from the subject of 
your post, it seems as though this is occurring the first time you build it, 
right? 

The output logs from the last build I did show: 

checking if you want to link with the GPM mouse library... maybe
checking for gpm.h... no 

for both builds. It looks to me like you might have a larger problem; my 
guess is that you're still using your build host's header files and 
libraries @ that point.  See "5.7. Adjusting the Toolchain"; by the time you 
reach first ncurses build (5.13) you should be using only the libraries etc. 
that you've built up to that point (from 5.7: "From this point onwards, 
everything will link only against the libraries in /tools/lib."). 

Unless you decided to install gpm very early on I don't see how you could 
have gpm.h, the gpm library, etc. at that point. 

I would suggest checking to see that your build environment is set up 
correctly.  Just a thought & I hope it helps. 

 - Larry 




More information about the lfs-support mailing list